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PowerXP
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Copyright © 2018 Altechna, UAB. All rights reserved.

No part of this manual, including the products and software described 
in it, may be reproduced, transmitted, transcribed, stored in a retrieval 
system, or translated into any language in any form or by any means, except 
documentation kept by the purchaser for backup purpose, without the 
express written permission of UAB Altechna (hereinafter Altechna).

Product warranty or service will not be extended if:

1. The product is repaired, modified or altered. Unless such repair, 
modification of alteration is authorized in writing by Altechna.

2. The serial number of the product is defaced or missing.

Altechna provides this manual “as is“ without warranty of any kind, either 
express or implied, including but not limited to the implied warranties or 
conditions of merchantability for a particular purpose. In no event shall 
altechna, its directors, employees or agents be liable for any indirect, 
special incidental, or cosequential damages (including damages for loss 
of profits, loss of business, loss of use or data, interuption of busines 
and the like), even if Altechna has been advised of the possibility of such 
damages arising from any defect or error in this manual or product.

Specifications and information contained in this manual are furnished 
for informational use only, and are subject to change at any time 
without notice, and should not be construed as a commitment by 
Altechna. Altechna assumes no responsibility or liability for any errors or 
inaccuracies that may appear in this manual, including the products and 
software described in it.



5

This manual is directly connected to fi rmware version. Latest 
fi rmware, soft ware and manual versions can be downloaded from 
www.altechna.com.

Products and corporate names appearing in this manual may or may not 
be registered trademarks or copyrights of their respective companies, and 
are used only for identifi cation or explanation and to the owner’s benefi t, 
without intent to infringe.
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1. Introduction
This user manual is designed to help to install and operate PowerXP. 
Before installing and operating PowerXP please read installation and 
operation instructions carefully. Safety instructions must be read carefully. 
If there are any questions about contents of this manual please contact 
info@altechna.com. Altechna reserves the right to update contents of this 
manual without any notification.

1.1. PowerXP short description

Compact motorized attenuator - PowerXP is a computer controlled laser 
beam attenuation device. It attenuates a free space laser beam/pulse 
continuously without introducing additional energy fluctuations. PowerXP is 
controlled by a computer via USB.

1.2. General safety requirements

Compact motorized attenuator is designed to operate in conjunction with 
laser systems. All applicable rules and regulations for safe operation of 
lasers must be known and applied while installing and operating PowerXP. 
The customer is solely responsible for laser safety while using PowerXP as a 
standalone device or integrated into system. The customer must consider 
protective measures.

While assembling or operating PowerXP, do not stare at the direct or 
scattered laser light even with safety goggles. All parts of the body must 
be kept away from the laser radiation. While adjusting laser beam through 
PowerXP, laser power must be kept as low as possible. Hazardous laser 
radiation can increase while optical components or instruments are used 
in combination with PowerXP. Appropriate eye protection must be worn at 
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all times. Electrical safety requirements must be complied while assembling 
and operating PowerXP.

1.3. Symbols

Warning!
Sections marked with this symbol explain dangerous situations that can 
result as personal injury or death. Always read the associated information 
carefully, before performing indicated procedure.

Attention!
Paragraphs preceded by this symbol explain hazards that could damage the 
instrument and connected equipment or may cause loss of data.

Note
This manual also contains “NOTES” and “HINTS” written in this form.

1.4. Regulation

Attention!
The following statement applies to the products covered in this manual, 
unless otherwise specifi ed herein. The statement for other products will 
appear in the accompanying documentation.

These limits are designed to provide reasonable protection against harmful 
interference in a residential installation. This equipment generates, uses, 
and can create radio frequency energy and, if not installed and used in 
accordance with the instructions, may cause harmful interference with 
radio communications. However, there is no guarantee that interference 
will not occur in a particular installation. If this equipment causes harmful 
interference to radio or television reception, which can be determined by 

 → Read further
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turning the equipment off and on, the user is encouraged to try to correct 
the interference by one or more of the following measures:

• Reorient or relocate the receiving antenna

• Increase the separation between the equipment and receiver

• Connect the equipment into an outlet on a circuit different from that to 
which the receiver is connected

• Consult the dealer or an experienced radio/TV technician for help

Altechna is not responsible for any radio or television interference caused 
by modifications of this equipment or the substitution or attachment of 
connecting cables and equipment other than those specified by Altechna. 
The correction of interference caused by unauthorized modification, 
substitution or attachment will be treated as responsibility of the user.

Attention!
Cellular phones or other radio transmitters are not recommended to be 
used within the range of three meters of this unit since the electromagnetic 
field intensity may then exceed the maximum allowed disturbance values 
according to IEC 61326-1.

1.5. Operating and storage conditions

For proper PowerXP functioning please use the assigned controller (found 
in the same package). Using unassigned controllers might be harmful to the 
device.

Environmental conditions that must be hold while storing, servicing and 
operating are:

• Storage temperature should be between -25 °C and +60 °C
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• Operating temperature is 25 °C ± 10 °C

• PowerXP must be protected from humidity, dust and corrosive vapors to 
avoid damaging optical components and electronics

• Avoid strong static electricity and electromagnetic fi elds
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2. Operation Principle

p-pol

Brewster type
thin film polarizer

Incident linearty
polarized laser beam

Rotating λ/2
waveplate

Beam dump

s-pol

Figure 1. PowerXP operation principle. The intensity of the incident beam is varied by means of 
a λ/2 phase waveplate and a polarizer.

PowerXP incorporates a rotating quartz λ/2 phase waveplate and one 
polarizer which separates s-polarized and p-polarized beams (fig. 1). 
The intensity ratio of the two beams may be continuously varied without 
alteration of other beam parameters by rotating the waveplate. Proper 
functioning of PowerXP requires optimal configuration of optical elements 
considering the polarization contrast of the incident laser beam. Higher 
incident laser beam polarization contrast leads to higher PowerXP output 
polarization contrast.
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3. Package contents
• Compact motorized attenuator - PowerXP

• Controller

• USB cable (2m length recomended but no longer than 3m)

• 12V power supply

• Soft ware, installation instructions in USB fl ash

• Polarizer – (already in the attenuator)

• Waveplate – (already in the attenuator)

3.1. Optics (dis)assembling

In order to get maximum possible attenuation polarizer adjustment 
is necessary. The back cover with beam dump can be removed by 
untightening two screws showed in fi g. 2. Aft er removing the closure, 
3 microscrews will be uncovered (circled in red). Adjusting them while 
measuring laser power output, will allow to reach maximum attenuation.

If necessary, the waveplate and polarizer holder can be removed for 
example for cleaning purposes. To remove the waveplate just untighten the 
retaining ring and take out the waveplate. For removing the polarizer holder 
please remove 3 steel screws and carefully pull it from the main PowerXP 
body.

 → Read further
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Figure 2. Disassembly of PowerXP. Adjustment microscrews circled in red. To remove the cover 
loosen two screws on each side of PowerXP (marked with yellow circle)

λ/2 waveplate
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4. PowerXP Soft ware Description
4.1. Computer requirements

• Free USB port. PowerXP is compatible with USB 1.1, USB 2.0 and USB 3.0 
Computer administrator rights (only for installation)

• Windows XP sp3 (32-bit)

• Windows Server 2003 sp2 (32-bit)

• Windows Vista sp1 (32/64-bit)

• Windows Server 2008 (32/64-bit)

• Windows 7(32/64-bit)

• Windows 8(32/64-bit)

• Microsoft .Net framework 4.0 redistributable (installs automatically)

 → Read further
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4.2. Software installation

1. Check for and download the latest “PowerXP” software installer package 
from http://www.altechna.com/product_details.php?id=1224&product 
_name=PowerXP+Compact+Motorized+Attenuator.

2. Run the downloaded “PowerXP-Setup.exe” installation file. In case 
the software is installed on an operating system that does not meet 
requirements, only USB drivers will be installed. Click “Yes” to continue.

3. Installation window will appear, click “Next” to continue:
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4. Click “Next”:

5. Select installation directory and click “Next” to begin installation:

 → Read further
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6. “PowerXP” software requires “Microsoft.NET Framework 4 Client Profile” 
or higher version to be installed. Setup will offer to download it, choose 
“Yes” if active internet connection is available. Choose “No” to download 
it from www.microsoft.com/enus/ download/details.aspx?id=17113 and 
install it manually. One should choose “No” if newer version of Microsoft.
NET framework is unwanted, or working internet connection is not 
available. This dialog will not appear if framework is already installed. 
Download size is 42 Mbytes.

8. After download is finished, “Microsoft .NET Framework 4 Client Profile” 
will be installed, wait for it to complete. This can take more than 10 
minutes on slower machine.

7. Setup will download “Microsoft .NET Framework 4 Client Profile”.
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9. Setup will fi nish by installing drivers. Click “Next” to continue:

 → Read further
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10. Click “Finish” to end installation. The program cannot be opened if only 
drivers were installed (see step 2 for details).

11. “PowerXP” software icon will appear on “All Users” desktop and “All 
Users” start menu.

12. Connect PowerXP to it’s controller.

13. Connect PowerXP controller and PC via USB cable.

14. Plug in PowerXP power supply jack.
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15. Windows will detect new hardware. Wait until windows confi gures new 
device.

4.3. Program fi rst run

Launch “PowerXP” program using “PowerXP” icon on desktop or from “Start 
Menu → All Programs → Altechna → PowerXP → PowerXP”. PowerXP “Selector” 
window will appear. At least one device must be displayed on the list. If the 
list is empty, please check USB cable, power connection. Blue LED must be 
active if power is OK. Click “File → Search For Devices” to refresh. For more 
information about PowerXP “Selector” window see section”

PowerXP “Selector” window”.

Select PowerXP from a list and click “File → Connect Once connected to 
PowerXP, dialog will pop up informing that no calibration fi le is found for 
new attenuator:

Figure 3. Dialog box, shown if PowerXP calibration fi le is not found.

 → Read further
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Select “OK”, calibration window will appear. Use instructions in section 
“Calibration” to setup calibration. After calibration is done, “PowerXP 
“control” window will appear. Use slider to select and set required power. 
See section “PowerXP “Control” window” window if more information is 
needed.

Column description:

• Name 
It is useful to give meaningful titles for each PowerXP, if more than one is 
used in the same system. For example, name can be set to “1st Harmonic 
WP”, and another attenuator can be named as “2nd Harmonic WP”. New 
name is saved into controller’s internal memory, so new name will be 
maintained on any computer. Name length is restricted to 20 characters 
maximum. PowerXP can be renamed from “PowerXP control” window 
“Options->PowerXP Name...” menu option.

4.4. PowerXP “Selector” window

PowerXP “Selector” window contains a list of currently connected and 
powered attenuators. This window is used to choose device to work with if 
there are several controllers connected to a single computer. Functions of 
this window are described in the picture below.

Figure 4. PowerXP “Selector“ window. It is displayed every time program is started. There is 
one device attached to PC in shown screenshot. Double click listed attenuator to open control 
window for it.
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• Serial Number
This column shows unique PowerXP controller hardware serial number. It 
is used to identify hardware at low level. Serial number must be used for 
hardware identifi cation when contacting the developers.

• COM port
Each PowerXP gets unique serial port name aft er fi rst enumeration 
with computer. This column shows USB serial port name assigned by 
Windows. COM port name is necessary to know for advanced users who 
want to use serial commands in their applications.

• Status
This column shows “Connected” if attenuator control window is active. 
Otherwise it is blank.

“File” menu description:

• Connect
Opens control window for selected PowerXP, (the same eff ect as double-
click on the device in the list. If only one device is connected during 
program startup, control window will be opened automatically. See 
chapter “PowerXP “Control” window” on page 24 for information.

• Search For Devices
Starts searching for PowerXP devices attached to computer. It can help if 
not all devices are detected and listed automatically.

• Close
Closes PowerXP “Selector” window, but leaves control windows opened.

• Exit
Closes PowerXP “Selector” and all control windows.

 → Read further
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“Help” menu description:

• User Manual 
Opens user manual

• About 
Shows software version and contact information.

4.5. Calibration

In order to correctly change the output power, the software needs to 
know the angle of the λ/2 waveplate’s fast axis. It can be fixed in any angle 
with respect to the rotator. The purpose of calibration is to fix angular 
offset between the λ/2 waveplate and the rotator hardware zero position. 
Calibration window is opened automatically on first use of PowerXP, or can 
be found in menu “Options → Calibration…” in “PowerXP control” window. 
Make sure that the attenuator is correctly aligned before calibrating.

Figure 5. Calibration window.
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Calibration procedure:

1. Homing. Click “Home” button in section “Step 1” and wait till motor 
stops. This will drive the waveplate holder to hardware limit switch (zero 
position). Step 1 must be performed every time the device is turned on 
or aft er extensive period of usage to eliminate any accumulated position 
error.

2. Rotate waveplate by using buttons in section “Step 3”, and measure 
laser power aft er the attenuator. Numbers on the buttons represent 
motor moving distance (expressed in stepper motor steps) and rotation 
direction. One step equals 0.003125.

Note
 It is advised to search for lowest power (max attenuation) position, 

because usually it can be spotted more easily and accurately.

3. Find minimum or maximum signal power and select the appropriate 
option in “Step 4”. It will be called “Home position” in the control window. 
Angular off set is recalculated and shown in “Step 7” fi eld every time 
“Step 4” selection is clicked. At this moment, main calibration goal is 
completed and “Apply” button can be clicked to apply changes. Further 
steps are not mandatory, but should be considered for convenience.

4. Calibration result can be verifi ed by using buttons in “Step 5” panel. 
Usage example: click “Drive to minimum power” button and wait till 
the rotator stops. Use buttons “-0,01” and “0,01” (located in “Step 2”) to 
ensure if current position is really of lowest power. If it is, click “Apply”, 
else select “Minimum power” in “Step 4” again, to redefi ne off set. The 
same can be done with maximum power point.

 → Read further
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5. Alignment of the polarizer and waveplate is critical for ensuring optimal 
performance, thus during the calibration PowerXP should be aligned to 
reach maximum performance. Real maximal and minimal transmitted 
power should be obtained by adjusting the polarizer with adjustment 
microscrews in the motorized attenuator (figure 2). Once measured, 
these extreme values should be entered in relevant fields of “Step 6”. 
Usage example: one uses 1 W laser, and 20 mW is measured as minimal 
power, and 0.99 W as maximal power. In such case firstly “Use absolute 
power measurement units” should be checked, then value “0.02” should 
be entered into field “Minimum measured value:”, and “0.99” – into 
“Maximum measured value:”, and “W” should be enreted into “Enter 
measurement units to use:” textbox, because measurement units are 
“Watts”.

6. Click “OK” button to accept calibration or “Cancel” to discard. If dialog, 
window-request go to zero position will appear, click “Yes” for correct 
device operation.

4.6. PowerXP “Control” window

PowerXP “Control” window is used to change laser power after PowerXP 
attenuator. Main components of this window are described below.

• PowerXP name and serial number is shown on each attenuator control 
window caption. Serial number is unique for each PowerXP controller 
and cannot be changed as it is used to identify hardware at low level.

• Power meter panel always shows existing power after the attenuator. 
Percentage range is from 0 % to 100 % of transmission. Zero percent 
means that waveplate occurs at 45 degrees angle, beam polarization 
is rotated by 90 degrees and is maximally attenuated. Display reading 
“100%” means that waveplate is rotated at minimum attenuation – 
maximum transmission angle.
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 If “Use absolute power measurement units” checkbox is set in “Options 
→ Preferences” or during calibrating, numeric display, showing “mW” 
becomes active. Absolute power reading is converted from percentage 
value with respect to minimal and maximal measured power using 
power meter. Correct min and max power values must be set in program 
preferences or calibration windows.

• Lower slider changes power from 0 % to 100 % with resolutuion of 
0.25%. Values in lower numeric fi elds will alter according to slider 
position. There is a triangle-shaped marker above lower slider which 
shows current power setting, which serves as convenient reference for 
slider usage.

• Enter required value (%) fi eld is used to manually enter percentage 
of PowerXP transmission. Decimal point symbol is “.” (dot), two decimal 
places can be used. Valid range is 0.00 % .. 100.00 %.

• Absolute required power fi eld is available if “Use absolute power 
measurement units” option is set in “Options → Preferences…” or 
“Options → Calibration…”. Decimal point symbol is “.” (dot). Valid range 
is from “Minimum measured value” to “Maximum measured value” set in 
program preferences.

Figure 6. Power meter panel: right - “Use absolute power measurement units” checkbox is 
set in “Options → Preferences”, left  - checkbox is unset.

 → Read further
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• Preset buttons can be used to quickly set discreet values of output 
power if absolute value was predefined in calibration stage. Left click on 
any of them and appropriate value will appear in (4) or (5) text boxes.

• “GO” button. Click to set power (rotate waveplate).

Note
 If “Automatically execute “GO” after required power change” is selected 

in “Options → Preferences” waveplate would rotate automatically after 
any of aforedescribed power control option is used (button pressed, slide 
moved, power value enteres, etc. Otherwise click “GO” button to actually 
set power.

• “STOP” button cancels rotation.

Figure 7. “Edit Preset Buttons at Preferences” window. Currently preset values are 0%, 25%, 
50%, 75%, 100% of transmission, because checkbox is unchecked. Otherwise all values 
would represent absolute power in user selected units.
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•  Buttons “<<” and “>>” will continuously decrease/increase power. 
Controller fi rmware must be up to date for these buttons to appear.

• “Home” button will drive waveplate rotator to home limit switch and 
back to “Home position”, set in “Options → Preferences…”. Usually this 
should be executed every time when device is turned on.

1. Watt Pilot name and serial number

9. Hold this button to constantly 
decrease power

9. Hold this button to constantly increase 
power

7. Click “GO” to apply power level which 
is shown in text boxes

5. Absolute required power fi eld is used 
to set power level using known units if 
correctly set in program preferences

4. Enter required power level here in 
percent. Click “GO” to set

6. Preset buttons instantly change 
required power

8. Immediately stops Watt Pilot rotation

2. “Power meter panel” Shows output 
power value, at which attenuator is 
currently set to

Output power level is always shown as 
percentage because it is directly related 
to waveplate angle

Power also can be shown with absolute 
measurement units if correctly set in 
program preferences

10. This will drive waveplate to “Home” 
position, set by calibration process and 
preferences

3. Move lower slider to change required 
power level. Click “GO” button to apply it

Upper indicator represents actual power 
level

Figure 8. PowerXP “Control” window. Currently laser power is set to 375 mW or 75 % of full 
calibrated range. Measurement units are available because absolute minimal and maximal 
power values are set in program preferences during calibration  process.
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“File” menu description:

• Save Calibration 
Current program settings can be saved to file. Configuration file includes 
all options in “Options → Preferences”, preset values and calibration 
offset. Run time program configuration files are saved in folder 
“Application data for all users\Altechna\PowerXP\ Settings”.

• Load Calibration 
Program settings can be restored from file. Configuration file includes all 
options in “Options → Preferences”, preset values and calibration offset. 
Current configuration will be overwritten.

• Show Device Selector 
Opens PowerXP “Selector” window.

• Close This Window 
Disconnects from PowerXP and closes active “Control” window.

“Options” menu description:

• Calibration 
Opens PowerXP calibration window. See chapter “Calibration” on page 
22 for details.

• Preferences 
Opens program configuration window. See chapter “Program preferences 
description” on page page 30 for details.

• PowerXP Name 
Opens “Rename Device” window. Use up to 20 characters for name. Enter 
new name and click “OK” to accept.
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Figure 9. “Rename Device” window.

“Help” menu description:

• User Manual
Opens user manual.

• About
Shows soft ware version and contact information. Please include soft ware 
version and controller serial number when contacting manufacturer.
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4.7. Program preferences

Preferences window can be accessed by “Options → Preferences” menu item 
in PowerXP control window.

Figure 10. Program preferences window. Can be found under menu “Options → Preferences”.

4.7.1. GUI input method options

• Set power on ”Enter” key press and preset button click. If checked, 
the power value will change by clicking “Enter” key after entering a 
required value.

• Set power when mouse leaves trackbar. If checked, the power value 
will change when mouse leaves the trackbar.
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• Set power in realtime when sliding trackbar. If checked, the power 
value will change while sliding the trackbar.

4.7.2. Controller buttons. Speed of attenuation

Start rotate with low speed

In this section rotation speed of attenuator could be easily changed by using 
a slider “…” (see Figure 10). Speed:

• Minimum speed is 0,004 steps/s

• Maximum speed is 50 steps/s

Jump to high speed aft er

You can set a time delay in ms for controller to change the speed to fast 
motion. Time before speed gets higher:

• Minimum time 0 ms

• Maximum time 2000 ms

If using a value >0ms it is necessary to set the speed value using a slider of 
High speed.

While using this option (value is >0ms) it is more accurate and easier to set 
the right value of attenuation when using buttons on a controller Left /Right 
or Min/Max (Figure 13). The rotator fi rstly will move with speed of “Start 
rotate with low speed” value, aft er set time it will start to move faster with 
set “High speed” value.

 → Read further
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Note:
“Automatically execute “GO” after required power change” must be checked 
for this options to be enabled.

• Use absolute measurement units for preset buttons. If this is set, preset 
button values are shown as absolute power values, otherwise, preset 
button values mean percentage (%) of transmitted power. Option “Use 
absolute power measurement units” must be set for this option to 
be enabled (see in calibration). Preset button values are recalculated 
automatically with respect to min and max measured power.

4.8. Red error signs in control window

Red error signs are dislplayed in control window:

Figure 11. PowerXP “Control” window with error signs (Home Alarm, Crc).
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• HOME!
Device is not homed aft er power on, so there is no accurate position 
reference point for the waveplate. Ratio readings are inaccurate, so ratio 
change is prohibited. Execute homing fi rst (hold MIN/MAX buttons for 
5sec or push home button in control window).

• ALARM!
Impossible to move motor - hardware error. Please check wiring, 
overheating, power supply.

• CRC!
Controllers calibration/settings are corrupt. Data corruption can 
occur due to power supply loss during calibration process. Please run 
calibration process.

4.9. Writing Soft ware for PowerXP

You can write your own soft ware for PowerXP. For this purpose a 
development kit is included for each PowerXP. This kit consists of: libraries 
for x32 and x64 architectures and header fi le; visual studio c example project 
with precompiled executables; LabView x32 & x64 2015 example project, 
which can read several parameters from controller; MATLAB example for x64 
architecture, which is tested with MATLAB R2015a x64 on Win10 x64. The kit 
includes wider descriptions and screenshots of how to use library fi les and 
provided examples.
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5. PowerXP Controller 
Hardware

5.1. Controller specifications

PowerXP controller is bipolar stepper motor driver with specifications listed 
in Table 1 below.

Table 1. Controller specifications

Max output voltage +12 V

Max output current 2 A

Current regulation type Pulse Width Modulation

Microstepping capability Steps 1/256

Position feedback Open loop operation (no external position 
feedback encoder)

Controller protection Driver have overheating and over current 
(2A) protection

Device can be operated by Computer software via USB port

Limit switch One limit switch can be connected and used 
only for homing

Connector 7 pin circular connector, 712 series
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5.2. Controller usage

Operation with buttons

• (-) – while holding turns the waveplate to a minimum attenuation

• (+) – while holding turns the waveplate to a maximum attenuation

• HOME – holding both (-/+) buttons for 5sec. moves attenuator to home 
position

 → Read further
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LED indicators - designation:

• Power – indicates power from USB connection with PC

• Status:

 · If blinking slowly (1 blink in 1 sec.) – need homing

 · If blinking fast (3 blinks in 1 sec.) – the waveplate is rotating

 · If iluminating continiously – PowerXP is homed, the movement is 
stopped

• (Min) – the PowerXP is at it‘s minimum attenuation

• (Max) – the PowerXP is at it‘s maximum attenuation
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Figure 12. PowerXP VGA connector pin out.

Figure 13. Bipolar stepper motor.

5.3. PowerXP connector pin out

MOTOR WIRES:

1. B\ Blue

2. B Red

3. A\ Green

4. A Black

OPTICAL SENSOR WIRES:

5. +5V Yellow

6. GND/Shiel

7. Signal/OUT White

Shaft

A Black

A\ Green

B 
Re

d

B\
 B

lu
e
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6. Main dimensions

6.1. PowerXP

Figure 14. Main dimensions and mounting options of PowerXP.
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6.2. PowerXP Controller

Figure 15. Main dimensions and mounting options of PowerXP Controller.
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